Hacker Rank C Challenges #003
Task
Given a positive integer denoting , do the following:
- If , print the lowercase English word corresponding to the number (e.g.,
one
for ,two
for , etc.). - If , print
Greater than 9
.
Input Format
The first line contains a single integer, .
Constraints
Output Format
If , then print the lowercase English word corresponding to the number (e.g., one
for , two
for , etc.); otherwise, print Greater than 9
instead.
Sample Input
5
Sample Output
five
Sample Input #01
8
Sample Output #01
eight
Sample Input #02
44
Sample Output #02
Greater than 9
code :
#include <assert.h>
#include <limits.h>
#include <math.h>
#include <stdbool.h>
#include <stddef.h>
#include <stdint.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char* readline();
int main()
{
char* n_endptr;
char* n_str = readline();
int n = strtol(n_str, &n_endptr, 10);
if (n_endptr == n_str || *n_endptr != '\0') { exit(EXIT_FAILURE); }
// Write Your Code Here
if (n==1){
printf("one");
}else if (n==2){
printf("two");
}else if (n==3){
printf("three");
}else if (n==4){
printf("four");
}else if (n==5){
printf("five");
}else if (n==6){
printf("six");
}else if (n==7){
printf("seven");
}else if (n==8){
printf("eight");
}else if (n==9){
printf("nine");
}else{
printf("Greater than 9");
}
return 0;
}
char* readline() {
size_t alloc_length = 1024;
size_t data_length = 0;
char* data = malloc(alloc_length);
while (true) {
char* cursor = data + data_length;
char* line = fgets(cursor, alloc_length - data_length, stdin);
if (!line) { break; }
data_length += strlen(cursor);
if (data_length < alloc_length - 1 || data[data_length - 1] == '\n') { break; }
size_t new_length = alloc_length << 1;
data = realloc(data, new_length);
if (!data) { break; }
alloc_length = new_length;
}
if (data[data_length - 1] == '\n') {
data[data_length - 1] = '\0';
}
data = realloc(data, data_length);
return data;
}
Comments
Post a Comment